Rails5.2.1+Bootstrap4でActionView::Template::Error (undefined not callable)が出た場合

目次

現象

Rails5 で Bootstrap4 を使おうとしてgem 'bootstrap', '~> 4.1.3'を Gemfile に追記すると、template の helper 部分でActionView::Template::Error (undefined not callable)が出る。

解決方法

Gemfile にあるgem 'duktape'をコメントアウトする。

原因&参考

https://github.com/twbs/bootstrap-rubygem/issues/157